This project has moved and is read-only. For the latest updates, please go here.

Is balance board working in v 1.6?

Jan 10, 2009 at 7:41 AM
I'm having trouble with balance board using v 1.6

When I run the test application, the WeightLb is always shown as -1003.341.  Putting pressure on the board does not change this value.  What am I missing?  If I check/uncheck the Outputs LED 1 checkbox the power light turns on/off so the board is connected.

Any help would be greatly appreciated.


Jan 10, 2009 at 9:50 PM
Edited Jan 10, 2009 at 9:51 PM

I and others are using the board successfully with v1.6 in various projects.  Are you able to connect and use a standard Wiimote controller?

Apr 24, 2009 at 5:38 PM

I'm working on a BalanceBoard project at university and we would like to use WiimoteLib.
First we tried v 1.7 and it worked well, but after a view runs of the test application we are experiencing the same problem as described above-
but with different values of the weights. Apart from that the LED1-checkbox works... Seems like the board is still connected, but doesn't deliver new weight values?
 I already tried v1.5.2, v1.6, everytime the same problem.

We are thankful for any help.

Apr 25, 2009 at 1:34 AM
there should be an update command. connect works too but I think if you can find update it would be better.
I am basing this on the wiimote's class. Idk if the balance board's class has it, but it's an idea to look into.

I'm not sure why my email to codeplex didnt add a post like it was supposed to, so I posted the email above manually.
Apr 25, 2009 at 6:09 PM
I've never been able to reproduce this in my testing.  Gaja, have you tried connecting a standard Wiimote instead of a BB, and if so, how does it behave?
Apr 26, 2009 at 6:20 AM
Speaking of wiimotes, does anyone know why the balance board acts as it's own wiimote but for some reason the extension is false and the extension type is null istead of balance board?

The bold part is the question.
Apr 27, 2009 at 4:00 PM

thanks for your answers- but seems we solved the problem.
It's the batteries...
We found it out trying to connect the Board to the Wii itself-
the batteries were almost empty, but probably enough for the LED.
In the WiimoteTest it doesn't show the correct battery-value for the Balance Board.
(I don't know if it is supposed to)

Apr 27, 2009 at 4:34 PM
lol wow. that's just bizarre.

no offense of course. I just think it's kinda funny how we went thru all this trouble when it was the batteries.

Maybe next time someone has a problem like this we should try that first :)
May 4, 2009 at 8:32 AM
"but for some reason the extension is false and the extension type is null istead of balance board?" SHOULD have an extension type of "ExtensionType.BalanceBoard" in the WiimoteState.ExtensionType parameter and Extension = true.  I think.  My BB is buried away at the moment...can anyone test this for me?