This project has moved and is read-only. For the latest updates, please go here.

Cannot find type System.ApplicationException in module mscorlib.dll

May 10, 2012 at 5:54 PM

For some reason all the time I reference the WiimoteLib to a project this Error is always displayed.

It used to work in older projects but now it works neither in VS 2010 nor in VS 2011 Beta.

Hope you can help me.

May 10, 2012 at 6:27 PM

Can you give me a bit more detail?  Are you seeing this when setting the reference?  When running the app?  What's the full exception information?

May 11, 2012 at 2:08 PM

Just when building this message Shows up in the error list and Interrupts the build. It appears before running the Application.

I actually don't know how to get a full error report. This is the only thing shown in the Error List

May 11, 2012 at 5:57 PM

If you switch over to the Output tab, you may find some additional information on the error.  Please copy/paste what's in that tab when you build and get the error.

May 11, 2012 at 10:56 PM

That's all what is written there:


------ Build started: Project: WiiTouch, Configuration: Debug Any CPU ------

C:\Program Files (x86)\MSBuild\Microsoft\WindowsXaml\v11.0\Microsoft.Windows.UI.Xaml.Common.targets(166,9): error : Cannot find type System.ApplicationException in module mscorlib.dll.

========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

========== Deploy: 0 succeeded, 0 failed, 0 skipped ==========

May 11, 2012 at 11:00 PM

Well, you're attempting to build a Metro/WinRT application with VS11 beta.  Unfortunately, this library will not work in a Metro/WinRT application as it is.  WinRT does not expose a HID layer (or a variety of other things) that would be required for this to work.

WiimoteLib is only supported in building Desktop applications with VS2010.

May 11, 2012 at 11:00 PM

Just to mention: All example Projects work on my computer. Only when I start a new one this Problem occurs.

May 11, 2012 at 11:07 PM

Hm. I just tried to build an desktop application with WiimoteLib and it works. But I have another VS2010 Desktop project where the same error occurs but where it used to work earlier.

Hm is there a possibility to use WiimoteLib in a Metro App anyway? Or will it be supported in future

May 11, 2012 at 11:10 PM

As I said above, there are a variety of things that WiimoteLib requires which WinRT does not expose.  Therefore, this library is not supported in WinRT/Metro-style application.

May 11, 2012 at 11:35 PM

Okay. Thank you for your time

Best regards